mirror of
https://github.com/librephoenix/nixos-config
synced 2025-01-18 22:55:52 +05:30
26 lines
629 B
Nix
26 lines
629 B
Nix
{ pkgs, userSettings, ... }:
|
|
|
|
{
|
|
# Home Manager needs a bit of information about you and the paths it should
|
|
# manage.
|
|
home.username = userSettings.username;
|
|
home.homeDirectory = "/home/"+userSettings.username;
|
|
|
|
programs.home-manager.enable = true;
|
|
|
|
imports = [
|
|
../../user/shell/sh.nix # My zsh and bash config
|
|
../../user/app/ranger/ranger.nix # My ranger file manager config
|
|
../../user/app/git/git.nix # My git config
|
|
];
|
|
|
|
home.stateVersion = "22.11"; # Please read the comment before changing.
|
|
|
|
home.packages = with pkgs; [
|
|
# Core
|
|
zsh
|
|
git
|
|
];
|
|
|
|
}
|