mirror of
https://github.com/librephoenix/nixos-config
synced 2025-01-18 22:55:52 +05:30
61 lines
1.2 KiB
Nix
61 lines
1.2 KiB
Nix
{ config, lib, pkgs, pkgs-stable, pkgs-emacs, systemSettings, userSettings, inputs, ... }:
|
|
|
|
{
|
|
# Simply install just the packages
|
|
environment.packages = with pkgs; [
|
|
# User-facing stuff that you really really want to have
|
|
vim # or some other editor, e.g. nano or neovim
|
|
|
|
# Some common stuff that people expect to have
|
|
procps
|
|
killall
|
|
diffutils
|
|
findutils
|
|
utillinux
|
|
tzdata
|
|
hostname
|
|
man
|
|
gnugrep
|
|
gnupg
|
|
gnused
|
|
gnutar
|
|
bzip2
|
|
gzip
|
|
xz
|
|
zip
|
|
unzip
|
|
git
|
|
];
|
|
|
|
# Backup etc files instead of failing to activate generation if a file already exists in /etc
|
|
environment.etcBackupExtension = ".bak";
|
|
|
|
# Read the changelog before changing this value
|
|
system.stateVersion = "23.11";
|
|
|
|
# Set up nix for flakes
|
|
nix.extraOptions = ''
|
|
experimental-features = nix-command flakes
|
|
'';
|
|
|
|
# Set your time zone
|
|
#time.timeZone = "Europe/Berlin";
|
|
|
|
# Configure home-manager
|
|
home-manager = {
|
|
backupFileExtension = "hm-bak";
|
|
useGlobalPkgs = true;
|
|
|
|
config = ./home.nix;
|
|
|
|
extraSpecialArgs = {
|
|
# pass config variables from above
|
|
inherit pkgs-stable;
|
|
inherit pkgs-emacs;
|
|
inherit systemSettings;
|
|
inherit userSettings;
|
|
inherit inputs;
|
|
};
|
|
};
|
|
}
|