mirror of
https://github.com/librephoenix/nixos-config
synced 2025-01-18 22:55:52 +05:30
36 lines
823 B
Nix
36 lines
823 B
Nix
{ config, pkgs, userSettings, ... }:
|
|
|
|
{
|
|
# Home Manager needs a bit of information about you and the paths it should
|
|
# manage.
|
|
home.username = userSettings.username;
|
|
home.homeDirectory = "/home/"+userSettings.username;
|
|
|
|
programs.home-manager.enable = true;
|
|
|
|
imports = [ ../work/home.nix # Personal is essentially work system + games
|
|
../../user/app/games/games.nix # Various videogame apps
|
|
];
|
|
|
|
home.stateVersion = "22.11"; # Please read the comment before changing.
|
|
|
|
home.packages = with pkgs; [
|
|
# Core
|
|
zsh
|
|
alacritty
|
|
brave
|
|
git
|
|
syncthing
|
|
|
|
];
|
|
|
|
xdg.enable = true;
|
|
xdg.userDirs = {
|
|
extraConfig = {
|
|
XDG_GAME_DIR = "${config.home.homeDirectory}/Media/Games";
|
|
XDG_GAME_SAVE_DIR = "${config.home.homeDirectory}/Media/Game Saves";
|
|
};
|
|
};
|
|
|
|
}
|