mirror of
https://github.com/librephoenix/nixos-config
synced 2025-01-18 22:55:52 +05:30
21 lines
578 B
Nix
21 lines
578 B
Nix
{ pkgs, ... }:
|
|
|
|
{
|
|
environment.systemPackages = with pkgs; [ firejail ];
|
|
programs.firejail.enable = true;
|
|
programs.firejail.wrappedBinaries = {
|
|
#prismlauncher = {
|
|
# executable = "${pkgs.prismlauncher}/bin/prismlauncher";
|
|
# profile = ./firejail-profiles/prismlauncher.profile;
|
|
#};
|
|
steam = {
|
|
executable = "${pkgs.steam}/bin/steam";
|
|
profile = "${pkgs.firejail}/etc/firejail/steam.profile";
|
|
};
|
|
steam-run = {
|
|
executable = "${pkgs.steam}/bin/steam-run";
|
|
profile = "${pkgs.firejail}/etc/firejail/steam.profile";
|
|
};
|
|
};
|
|
}
|