mirror of
https://github.com/librephoenix/nixos-config
synced 2025-01-18 22:55:52 +05:30
15 lines
322 B
Nix
15 lines
322 B
Nix
{ userSettings, authorizedKeys ? [], ... }:
|
|
|
|
{
|
|
# Enable incoming ssh
|
|
services.openssh = {
|
|
enable = true;
|
|
openFirewall = true;
|
|
settings = {
|
|
PasswordAuthentication = false;
|
|
PermitRootLogin = "no";
|
|
};
|
|
};
|
|
users.users.${userSettings.username}.openssh.authorizedKeys.keys = authorizedKeys;
|
|
}
|