mirror of
https://github.com/librephoenix/nixos-config
synced 2025-01-18 22:55:52 +05:30
42 lines
886 B
Nix
42 lines
886 B
Nix
{ inputs, pkgs, lib, ... }: let
|
|
pkgs-hyprland = inputs.hyprland.inputs.nixpkgs.legacyPackages.${pkgs.stdenv.hostPlatform.system};
|
|
in
|
|
{
|
|
# Import wayland config
|
|
imports = [ ./wayland.nix
|
|
./pipewire.nix
|
|
./dbus.nix
|
|
];
|
|
|
|
# Security
|
|
security = {
|
|
pam.services.login.enableGnomeKeyring = true;
|
|
};
|
|
|
|
services.gnome.gnome-keyring.enable = true;
|
|
|
|
programs = {
|
|
hyprland = {
|
|
enable = true;
|
|
package = inputs.hyprland.packages.${pkgs.system}.hyprland;
|
|
xwayland = {
|
|
enable = true;
|
|
};
|
|
portalPackage = pkgs-hyprland.xdg-desktop-portal-hyprland;
|
|
};
|
|
};
|
|
|
|
services.xserver.excludePackages = [ pkgs.xterm ];
|
|
|
|
services.xserver = {
|
|
displayManager.sddm = {
|
|
enable = true;
|
|
wayland.enable = true;
|
|
enableHidpi = true;
|
|
theme = "chili";
|
|
package = pkgs.sddm;
|
|
};
|
|
|
|
};
|
|
}
|