nixos-config/system/wm/wayland.nix
2024-08-16 13:53:53 -05:00

33 lines
661 B
Nix

{ config, pkgs, ... }:
{
imports = [ ./pipewire.nix
./dbus.nix
./gnome-keyring.nix
./fonts.nix
];
environment.systemPackages = with pkgs;
[ wayland waydroid
(sddm-chili-theme.override {
themeConfig = {
background = config.stylix.image;
ScreenWidth = 1920;
ScreenHeight = 1080;
blur = true;
recursiveBlurLoops = 3;
recursiveBlurRadius = 5;
};})
];
# Configure xwayland
services.xserver = {
enable = true;
xkb = {
layout = "us";
variant = "";
options = "caps:escape";
};
};
}