mirror of
https://github.com/librephoenix/nixos-config
synced 2025-01-18 22:55:52 +05:30
33 lines
661 B
Nix
33 lines
661 B
Nix
{ config, pkgs, ... }:
|
|
|
|
{
|
|
imports = [ ./pipewire.nix
|
|
./dbus.nix
|
|
./gnome-keyring.nix
|
|
./fonts.nix
|
|
];
|
|
|
|
environment.systemPackages = with pkgs;
|
|
[ wayland waydroid
|
|
(sddm-chili-theme.override {
|
|
themeConfig = {
|
|
background = config.stylix.image;
|
|
ScreenWidth = 1920;
|
|
ScreenHeight = 1080;
|
|
blur = true;
|
|
recursiveBlurLoops = 3;
|
|
recursiveBlurRadius = 5;
|
|
};})
|
|
];
|
|
|
|
# Configure xwayland
|
|
services.xserver = {
|
|
enable = true;
|
|
xkb = {
|
|
layout = "us";
|
|
variant = "";
|
|
options = "caps:escape";
|
|
};
|
|
};
|
|
}
|