mirror of
https://github.com/librephoenix/nixos-config
synced 2025-01-18 22:55:52 +05:30
36 lines
634 B
Nix
36 lines
634 B
Nix
{ pkgs, ... }:
|
|
{
|
|
# Collection of useful CLI apps
|
|
home.packages = with pkgs; [
|
|
# Command Line
|
|
disfetch lolcat cowsay
|
|
starfetch
|
|
cava
|
|
killall
|
|
libnotify
|
|
timer
|
|
brightnessctl
|
|
gnugrep
|
|
bat eza fd bottom ripgrep
|
|
rsync
|
|
unzip
|
|
w3m
|
|
pandoc
|
|
hwinfo
|
|
pciutils
|
|
numbat
|
|
(pkgs.callPackage ../pkgs/pokemon-colorscripts.nix { })
|
|
(pkgs.writeShellScriptBin "airplane-mode" ''
|
|
#!/bin/sh
|
|
connectivity="$(nmcli n connectivity)"
|
|
if [ "$connectivity" == "full" ]
|
|
then
|
|
nmcli n off
|
|
else
|
|
nmcli n on
|
|
fi
|
|
'')
|
|
vim neovim
|
|
];
|
|
}
|